Repository navigation
docs: correct the README's requirements, setup and privacy notes - #20
Merged
Merged
Conversation
- Requirements: Flutter 3.38.1+, Dart 3.10+, iOS 13.0+, Android API 24+. Every app_links version the SDK accepts needs iOS 13 and minSdk 24, and the oldest needs Flutter 3.38.1 (as do device_info_plus 13.1 and package_info_plus 10.1); the README said Flutter 3.10, iOS 12, API 21. - Flutter's built-in deep linking: since Flutter 3.27 it's on by default and conflicts with app_links, so it must be turned off, not only "if you also use it". Adds the opt-out snippets from Flutter's breaking-change note to Platform Setup (the iOS key takes <false/>, not NO). - Quick Start: shows appToken, and says apiKey is only needed for createLink. - Privacy: no advertising IDs is the accurate claim; installs on Android are matched by the Play install referrer where available; the SDK stores the install ID the server assigns. Data collected now lists the platform, the Play install referrer and an optional app-supplied device ID. - Android setup: minSdk 24 and the Play App Signing fingerprint.
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Brings the README in line with what 0.6.0 actually needs and does.
Requirements
The README said Flutter 3.10+, Dart 3.0+, iOS 12.0+ and Android API 21+. The SDK's dependencies set a higher floor:
app_links7.x,device_info_plus13.1 andpackage_info_plus10.1 each requireflutter >=3.38.1sdk >=3.10.0app_linksversion:platform :ios, '13.0'app_linksversion:minSdk = 24Checked against the pubspecs on pub.dev for the minimum versions the constraints allow, and against
app_links7.0.0 and 7.2.2's podspec andbuild.gradle.Suggested follow-up:
pubspec.yamlstill declaresflutter: '>=3.10.0'andsdk: '>=3.0.0'. Raising them to>=3.38.1and>=3.10.0would make pub's error point at the real requirement. It's a metadata change for the next release.Flutter's built-in deep linking
Since Flutter 3.27 the built-in handler is on by default. Flutter's breaking-change note says apps using
app_linksmust opt out. The README presented it as optional ("if you also use Flutter's built-in deep linking") and gave the iOS value asNO. It's now a Platform Setup step, with the note's snippets (<false/>on iOS).Quick Start
appToken, which 0.6.0 supports and the hosted service requires.apiKeyis only needed forcreateLink().flutter analyzereports no issues on the updated Quick Start againstlinkforty_flutter0.6.0.Privacy
clearData()removes it.deviceId.Note
pub.dev shows the README from the published package, so these changes appear there with the next release; GitHub shows them on merge.