Skip to content

Forbidden Error - Exception raised when calling init #65

Description

@sajankgit

Hi Team,

I have followed https://cdap.atlassian.net/wiki/spaces/DOCS/pages/911179793/Installation+on+Kubernetes to install cdap in kubernetes (Google Kubernetes Engine)

However, getting the following error:

SLF4J: Actual binding is of type [ch.qos.logback.classic.util.ContextSelectorStaticBinder]
2021-03-23 10:12:13,015 - INFO [main:i.c.c.m.e.k.AbstractServiceMain@127] - Initializing master service class io.cdap.cdap.master.environment.k8s.MetadataServiceMain
2021-03-23 10:12:14,233 - DEBUG [main:i.c.c.c.g.DFSLocationModule$LocationFactoryProvider@76] - Location namespace is /cdap
2021-03-23 10:12:14,438 - WARN [main:o.a.h.u.NativeCodeLoader@62] - Unable to load native-hadoop library for your platform... using builtin-java classes where applicable
2021-03-23 10:12:14,532 - DEBUG [main:i.c.c.c.g.FileContextProvider@68] - Getting filesystem for user root
2021-03-23 10:12:15,863 - INFO [main:i.c.c.m.e.k.KubeMasterEnvironment@104] - Initializing Kubernetes environment
2021-03-23 10:12:16,387 - ERROR [main:i.c.c.c.r.DaemonMain@41] - Exception raised when calling init
io.kubernetes.client.ApiException: Forbidden
at io.kubernetes.client.ApiClient.handleResponse(ApiClient.java:882) ~[na:na]
at io.kubernetes.client.ApiClient.execute(ApiClient.java:798) ~[na:na]
at io.kubernetes.client.apis.CoreV1Api.readNamespacedPodWithHttpInfo(CoreV1Api.java:25009) ~[na:na]
at io.kubernetes.client.apis.CoreV1Api.readNamespacedPod(CoreV1Api.java:24991) ~[na:na]
at io.cdap.cdap.master.environment.k8s.KubeMasterEnvironment.createPodInfo(KubeMasterEnvironment.java:245) ~[na:na]
at io.cdap.cdap.master.environment.k8s.KubeMasterEnvironment.initialize(KubeMasterEnvironment.java:114) ~[na:na]
at io.cdap.cdap.master.environment.k8s.AbstractServiceMain.init(AbstractServiceMain.java:154) [io.cdap.cdap.cdap-app-fabric-6.5.0-SNAPSHOT.jar:na]
at io.cdap.cdap.common.runtime.DaemonMain.doMain(DaemonMain.java:39) ~[io.cdap.cdap.cdap-common-6.5.0-SNAPSHOT.jar:na]
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[na:1.8.0_282]
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[na:1.8.0_282]
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[na:1.8.0_282]
at java.lang.reflect.Method.invoke(Method.java:498) ~[na:1.8.0_282]
at io.cdap.cdap.master.environment.k8s.AbstractServiceMain.main(AbstractServiceMain.java:121) [io.cdap.cdap.cdap-app-fabric-6.5.0-SNAPSHOT.jar:na]
at io.cdap.cdap.master.environment.k8s.MetadataServiceMain.main(MetadataServiceMain.java:70) [io.cdap.cdap.cdap-master-6.5.0-SNAPSHOT.jar:na]
2021-03-23 10:12:16,398 - ERROR [main:i.c.c.c.r.DaemonMain@45] - Exception raised when calling destroy
io.kubernetes.client.ApiException: Forbidden
at io.kubernetes.client.ApiClient.handleResponse(ApiClient.java:882) ~[na:na]
at io.kubernetes.client.ApiClient.execute(ApiClient.java:798) ~[na:na]
at io.kubernetes.client.apis.CoreV1Api.readNamespacedPodWithHttpInfo(CoreV1Api.java:25009) ~[na:na]
at io.kubernetes.client.apis.CoreV1Api.readNamespacedPod(CoreV1Api.java:24991) ~[na:na]
at io.cdap.cdap.master.environment.k8s.KubeMasterEnvironment.createPodInfo(KubeMasterEnvironment.java:245) ~[na:na]
at io.cdap.cdap.master.environment.k8s.KubeMasterEnvironment.initialize(KubeMasterEnvironment.java:114) ~[na:na]
at io.cdap.cdap.master.environment.k8s.AbstractServiceMain.init(AbstractServiceMain.java:154) [io.cdap.cdap.cdap-app-fabric-6.5.0-SNAPSHOT.jar:na]
at io.cdap.cdap.common.runtime.DaemonMain.doMain(DaemonMain.java:39) ~[io.cdap.cdap.cdap-common-6.5.0-SNAPSHOT.jar:na]
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[na:1.8.0_282]
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[na:1.8.0_282]
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[na:1.8.0_282]
at java.lang.reflect.Method.invoke(Method.java:498) ~[na:1.8.0_282]
at io.cdap.cdap.master.environment.k8s.AbstractServiceMain.main(AbstractServiceMain.java:121) [io.cdap.cdap.cdap-app-fabric-6.5.0-SNAPSHOT.jar:na]
at io.cdap.cdap.master.environment.k8s.MetadataServiceMain.main(MetadataServiceMain.java:70) [io.cdap.cdap.cdap-master-6.5.0-SNAPSHOT.jar:na]

I have tried give cluster role admin role to the service account, still getting Forbidden error. Can you please help me to figure out the issue?

Regards,

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions