test cdc/frontier-persistence-benchmark/interval=30s/tables=1/ranges=10000 failed: (test_runner.go:1087).func4: in provider: aws: failed to create instance teamcity-21530045-1790234293-20-n4cpu16-0001: aws create failed due to capacity for machine type m6id.4xlarge in zone(s) [us-east-2c]; suggested zone(s): [us-east-2a us-east-2b]: failed to run: aws ec2 run-instances --associate-public-ip-address --count 1 --instance-type m6id.4xlarge --image-id ami-0e83be366243f524a --key-name teamcity-runner-SmQLdL0SwDdWigwMsLH-1fj-0zk= --region us-east-2 --security-group-ids sg-04d72b57e29d671f1 --subnet-id subnet-0e71591c1fe06645e --tag-specifications ResourceType=instance,Tags=[{Key=usage,Value=roachtest},{Key=roachtest-branch,Value=basalt-26-3-2-rc-20260916},{Key=created,Value=2026-09-24T07:47:36Z},{Key=spot,Value=true},{Key=arch,Value=amd64},{Key=Name,Value=teamcity-21530045-1790234293-20-n4cpu16-0001},{Key=roachprod-data-disk,Value=local},{Key=Cluster,Value=teamcity-21530045-1790234293-20-n4cpu16},{Key=roachprod,Value=true},{Key=cluster,Value=teamcity-21530045-1790234293-20-n4cpu16},{Key=lifetime,Value=12h0m0s}] ResourceType=volume,Tags=[{Key=usage,Value=roachtest},{Key=roachtest-branch,Value=basalt-26-3-2-rc-20260916},{Key=created,Value=2026-09-24T07:47:36Z},{Key=spot,Value=true},{Key=arch,Value=amd64},{Key=Name,Value=teamcity-21530045-1790234293-20-n4cpu16-0001},{Key=roachprod-data-disk,Value=local},{Key=Cluster,Value=teamcity-21530045-1790234293-20-n4cpu16},{Key=roachprod,Value=true},{Key=cluster,Value=teamcity-21530045-1790234293-20-n4cpu16},{Key=lifetime,Value=12h0m0s}] --user-data file:///tmp/aws-startup-script1392939261 --iam-instance-profile Name=roachprod-testing --block-device-mapping file:///tmp/aws-block-device-mapping1213086519 --instance-market-options MarketType=spot,SpotOptions={SpotInstanceType=one-time,InstanceInterruptionBehavior=terminate} --output json: stderr:
An error occurred (InsufficientInstanceCapacity) when calling the RunInstances operation (reached max retries: 2): We currently do not have sufficient m6id.4xlarge capacity in the Availability Zone you requested (us-east-2c). Our system will be working on provisioning additional capacity. You can currently get m6id.4xlarge capacity by not specifying an Availability Zone in your request or choosing us-east-2a, us-east-2b.: exit status 254 [owner=test-eng]
roachtest.cluster_creation failed with artifacts on basalt-26.3.2-rc-20260916 @ 54500d5b171ef1715a0773abf24a2463cf6d1107:
Parameters:
cloud=awscoverageBuild=falsecpu=16diskCount=0runtimeAssertionsBuild=falseHelp
See: roachtest README
See: How To Investigate (internal)
Same failure on other branches
This test on roachdash | Improve this report!
Jira issue: CRDB-68801