Skip to content

roachtest: cluster_creation failed #175986

Description

@cockroach-teamcity

roachtest.cluster_creation failed with artifacts on release-25.4.18-rc @ 7ab8b6bfe71166fede4ba7f5e17270bddecea4ef:

test cdc/multi-table-pts-benchmark/per-table-pts=false/num-tables=50000/num-ranges=1 failed: (test_runner.go:901).func4: in provider: aws: aws create failed due to capacity for machine type m6id.4xlarge in zone(s) [us-east-2b]; suggested zone(s): [us-east-2a us-east-2c]: failed to run: aws ec2 run-instances --associate-public-ip-address --count 1 --instance-type m6id.4xlarge --image-id ami-0e83be366243f524a --key-name teamcity-runner-jGElPdM5aq9zbS7-sCcObmUTn3w= --region us-east-2 --security-group-ids sg-04d72b57e29d671f1 --subnet-id subnet-0e3d146e87ebc5a2c --tag-specifications ResourceType=instance,Tags=[{Key=usage,Value=roachtest},{Key=roachtest-branch,Value=release-25-4-18-rc},{Key=created,Value=2026-10-01T06:04:26Z},{Key=Name,Value=teamcity-21537671-1790833222-21-n4cpu16-0001},{Key=Cluster,Value=teamcity-21537671-1790833222-21-n4cpu16},{Key=spot,Value=true},{Key=roachprod,Value=true},{Key=cluster,Value=teamcity-21537671-1790833222-21-n4cpu16},{Key=lifetime,Value=12h0m0s},{Key=arch,Value=amd64}] ResourceType=volume,Tags=[{Key=usage,Value=roachtest},{Key=roachtest-branch,Value=release-25-4-18-rc},{Key=created,Value=2026-10-01T06:04:26Z},{Key=Name,Value=teamcity-21537671-1790833222-21-n4cpu16-0001},{Key=Cluster,Value=teamcity-21537671-1790833222-21-n4cpu16},{Key=spot,Value=true},{Key=roachprod,Value=true},{Key=cluster,Value=teamcity-21537671-1790833222-21-n4cpu16},{Key=lifetime,Value=12h0m0s},{Key=arch,Value=amd64}] --user-data file:///tmp/aws-startup-script3562614617 --iam-instance-profile Name=roachprod-testing --block-device-mapping file:///tmp/aws-block-device-mapping2804289564 --instance-market-options MarketType=spot,SpotOptions={SpotInstanceType=one-time,InstanceInterruptionBehavior=terminate} --output json: stderr: 
An error occurred (InsufficientInstanceCapacity) when calling the RunInstances operation (reached max retries: 2): We currently do not have sufficient m6id.4xlarge capacity in the Availability Zone you requested (us-east-2b). Our system will be working on provisioning additional capacity. You can currently get m6id.4xlarge capacity by not specifying an Availability Zone in your request or choosing us-east-2a, us-east-2c.: exit status 254 [owner=test-eng]

Parameters:

  • cloud=aws
  • coverageBuild=false
  • cpu=16
  • runtimeAssertionsBuild=false
  • ssd=0
Help

See: roachtest README

See: How To Investigate (internal)

Same failure on other branches

/cc @cockroachlabs/test-eng

This test on roachdash | Improve this report!

Jira issue: CRDB-69067

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    O-roachtestO-robotOriginated from a bot.T-testengTestEng TeamX-infra-flakethe automatically generated issue was closed due to an infrastructure problem not a product issuebranch-release-25.4.18-rc

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions